پنج‌شنبه 6 آبان 1400
خانه / وردپرس فارسی / اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن

اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن

اگر شما هم با خطای «منطقه زمانی پیشفرض PHP نامعتبر است» در بخش سلامت سایت وردپرسی خود رو به رو شدید با بخش آموزش وردپرس ، گالری سرور همراه باشید تا این خطا را برطرف کنیم. با آمدن آپدیت های جدید وردپرس نیاز است که پلاگین ها خود را با نسخه جدید وردپرس بروزرسانی نمایند و کدهایی که تغییر یافته است را درون سایت خود تغییر دهند.

بعضی از کاربران وردپرس فارسی گزارش کردند اخیرا و بعد از به روز رسانی وردپرس خود به نسخه ۵٫۴ و یا نسخه های بالاتر با خطای زیر در بخش سلامت سایت رو به رو شدند :

اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن
اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن

در متن این خطا نوشته شده «منطقه زمانی پیشفرض PHP پس از بارگذاری وردپرس با فراخوانی date_default_timezone_set() تابع تغییر یافته است. این عملکرد با محاسبات صحیح تاریخ و زمان تداخل ایجاد میکند.»

اما مشکل از کجاست؟

افزونه وردپرس فارسی wp-jalali در بخش تنظیمات یک گزینه برای تنظیم ساعت زمانی پیش فرض وردپرس در منطقه زمانی ایران/تهران دارد که در صورت فعال بودن این گزینه بعد از وردپرس نسخه ۵٫۴ و بالاتر با این مشکل رو به رو می شوید.

برای حل این مشکل کافی است طبق عکس راهنمای زیر در بخش تنظیمات تیک علامت دار این گزینه را برداشته تا غیرفعال شود :

اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن
اخطار منطقه زمانی پیش فرض php در وردپرس فارسی و راههای برطرف کردن آن

مطابق تصویر به بخش وردپرس فارسی در پیشخوان خود رفته و گزینه ای که نشان داده شده است را غیر فعال کنید.

در صورتی که با غیر فعال کردن این گزینه منطقه زمانی سایت شما به هم ریخت کافی است به بخش تنظیمات عمومی پیشخوان وردپرس خود رفته و در قسمت زمان محلی منطقه زمانی مورد نظر یعنی شهر تهران را انتخاب کنید.

نکته قابل توجه بعضی از سایت ها پیشنهاد تغییر افزونه فارسی ساز و یا حتی ویرایش کدهای افزونه را می دهند که به هیچ وجه لازم نیست و می توانید به راحتی با غیر فعال کردن گزینه گفته شده این مشکل را حل کنید.

روش دوم :

اگر شما از افزونه وردپرس فارسی استفاده نمیکنید ، برای رفع مشکل منطقه زمانی پیشفرض می توانید از سایر افزونه های فارسی ساز استفاده کنید.

مجموعه نمای من از میان افزونه های فارسی ساز ، افزونه wp parsi date را تست نموده است که این مشکل را با آپدیت جدید وردپرس ندارد.

جهت دریافت افزونه می توانید از لینک زیر استفاده کنید.

 

 

شما دوست گرامی می توانید برای مشاهده دوره های آموزش استاندارد طراحی سایت با وردپرس از فروشگاه ما دیدن نمایید.

درباره‌ی gserver

نویسنده: مهران در رشته نرم افزار تحصیل کردم و حدود یک سال است که به عنوان کارشناس محتوا افتخار همکاری در مجموعه گالری سرور را دارم. به مباحث بازاریابی موتورهای جستجو، بهینه‌سازی صفحات وب برای موبایل و راهکارهای بهبود نرخ تبدیل علاقه‌مند هستم.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *